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MECHANISMU  

CÍL 
Toto cvičení bude mít za úkol projít modul mechanismu. První části se zaměříme na mechanismus 
obecného charakteru. V další části ukážeme mechanismy konkrétních strojních součástí. 
 
 
 
 
 
 

Předpoklady 
 
 Znalost zakladního popisu 
 
 

PROBÍRANÉ PRVKY, FUNKCE A POSTUPY  

 
 Link 
 Joint 
 Coupler 
 Connector 
 Constrain 
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Kapitola 1 - Obecný mechanismus 
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Krok č.1 Otevření sestavy 
 
1. Klikněte na           . 
 
2.   V okně OPEN otevřete položku mechanismus (Najdete jej ve vámi zvoleném adresáři s uloženými   
      CAD daty). 
3.   Dole klikněte na  Options... → Model data →  
      zaškrtněte surface a solids 
4.   Potvrďte tlačítkem OK .   
 
 
 
 
 
 
Potřebné CAD data naleznete na courseware u  
předmětu KKS/KPP  → Studijní materiály →   
sw NX → Založka mechanismu.          
 
 
 
 
 
 

Krok č.2 Přepnutí do Motion simulation  

    Při otevření sestavy máme nahrané jednotlivé díly mechanismu. Přejdeme z prostředí modeláře do    
    prostředí mechanismu.  
 
1. V ikonovém menu  na ikonu                    po jejím rozbalení přejdeme do prostředí  Motion  
    Simulation  (mechanismu). 
 
Nyní nastala změna prostředí je zapotřebí vytvořit novou  
Simulaci. 
2. V Motion Navigator klineme pravým tlačítkem myši na  
Obecny_mechanismu a dáme New Simulation. 
 
 
 
 
 
 
3. V okně Enviroment záložce Analysis type označíme  
    Dynamics a Component-based Simulation 
    Ostatní položky necháme odškrtnuté. 
 
Rozdíl mezi Kinematikou a dynamikou. 
V kinematickém řešení - nezahrnuje gravitaci a hmotu jednotlivých součástí 
                                      - jednotlivé modely jsou považovány za tuhé 
                                      - zahrnuje vnější a vnitřní síly ne však v závislosti na pohybu 
                                      - nezahrnuje kontakty  
                                      - mechanismus nemůže mít víc jak jeden stupen volnosti 
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V dynamickém řešení  - zahrnuje gravitaci a hmotu jednotlivých součástí                                      
                                     - zahrnuje vnější a vnitřní síly, které ovlivňují pohyb mechanismu 
                                     - zahrnuje kontakty  
                                     - mechanismus může mít víc jak jeden stupen volnosti 
 
4. Klikneme na OK. 
 
Nyní jsem se přepnuli z *.prt do *.sim 
 
 
 
 
 
5. Klikneme-li pravým tlačítkem myši na  motion_1 můžeme přepsat název přes rename → 
Obecny_mechanismus_1 
 
 
 
 
 
 
 

 
Simulaci uložíme. 
 

Krok č.3 Vytvoření jednotlivých linků 
 
Ikona  
 
link - jedná se o těleso v mechanismu 
       - v sestavě definujeme pohyblivé části  
       - vyskytuje-li se v sestavě více vůči sobě nepohyblivých součástí 
          např. hřídel, pero a náboj definujeme je jako jeden link.  
       - nepohybující se součásti definujeme jako pevný nebo-li Fix-link 
          
1. Při jeho otevření se nám otevře tabulka   
     
Záložka Link Objects - v pracovní ploše vybereme příslušný link  
 
Záložka Mass properties option -  
                                    Automatic - program na základě geometrie a  
                                    přiřazeného materiálu, sám určí těžiště a jeho  
                                    rozložení hmoty okolo Hlavních centrálních os  
                                    a rovin 
                                 -  User Defined - Možnost uživatelského určení  
                                    hmotnosti a její rozložení okolo Hlavních  
                                    centrálních os a rovin, které je možné nastavit  
                                    v záložce Mass and Inertia  
V případě že by byl nahrán objekt jako plocha. Bylo by nutné tyto  
parametry uživatelem dodefinovat. 
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Záložka Initial Translation Velocity umožní nastavení počátečního  
posunutí vybraného členu 
 
Záložka Initial Rotation Velocity umožní nastavení počáteční  
rotace vybraného členu  
 
Záložka Settings  - Zaškrtnutím určíme nepohyblivý link 
Záložka Name - Vytvoření popisu vybraného členu  (např. ozubene_kolo) 
 
                                                                                  2. Prvotně vytvoříme fix link na motoru, jeho desce a  
                                                                                      Lineárním vedení.  
                                                                                      Označíme komponenty dle obrázku 
                                                                                      Nastavení tabulky - Mass properties option - 
                                                                                                                      Automatic 
                                                                                      Ostatní položky ponecháme uzavřené  
                                                                                      Settings - zaškrtneme Fix Link 
                                                                                      Name - Motor_Vedeni 
 
                                                                                     V Motion navigator se zobrazil Joint (jeho  
                                                                                      podrobný popis si ukážeme v dalším kroku) 
                                                                                  3. Klikneme na Apply (Pro další kroky bude tabulka  
                                                                                       otevřena) 
 
 
 
4. Vytroříme link ozubeného kolečka u motoru 
    Nastavení tabulky - Mass properties option - 
                                    Automatic 
    Ostatní položky ponecháme uzavřené  
    Settings - nezaškrtávat Fix Link 
    Name - Ozubene_kolecko 
5. Klikneme na Apply 
    Toto nastavení bude ponecháno i pro další  
    Komponenty, nebude-li jinak v textu uvedeno. 
 
6. Vytvoříme link na hnaném ozubeném kole 
    a jeho společních komponentech  
    To znamená označíme celkem 6 součásti,  
    které se vůči sobě nepohybují (Velké ozubené  
    kolo, hřídel, kolo s drážkou, čep u kola,  
    rameno a čep u ojnice) 
 
    Name - Ozubene_Kolo_hridel_drazka_cep 
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                                                                                                           Čep u ojnice (vzdálenější od motoru) 
 
 
 
 
 
 
 
 
 
 
8. Nyní označíme ojnici (vzdálenější od motoru) 
 
Name:  Ojnice_1 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                                                                                                   9. Další označíme ojnici (bližší k motoru) 
                                                                                                       Name:  Ojnice_2 
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10.  Označíme kluzné vedení (vzdálenější od motoru) 
     Name:  Kluzne_vedeni_cep_1 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
11.  Označíme kluzné vedení (bližší k motoru) 
     Name:  Kluzne_vedeni_cep_2 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                                                                                        12.  Tyč umístěnou ve vedení 2 a fialové objímce  
                                                                                                     Name:  Tyc 
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13.  Označíme ramennou páku u kluzného vedení 1 
      Name:  Ramenna_paka 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
14.  Označíme objímku v ramenné páce  
       Name:  Objimka 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
15.  Označíme kloubovou tyč  
       Name:  Kloubova_tyc 
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                                                                                     16.  Označíme rameno u kloubové tyče  
                                                                                           Name:  Rameno 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
17. Označíme Kulovou tyč mezi ramenem a drazkou 
      Name:  Kulova_tyc 
 
18. Celkový strom linků v mechanismu 
 
                                                                  19. Označíme-li ve stromě například link Motor_vedeni.  
                                                                        Vybraný komponent se na pracovní ploše zvýrazní                                                                  
                                                                        oranžovou barvou a ve stromě se u Jointu popis změní na  
                                                                        modré písmo. V opačném případě je nápis linku červený. 
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Krok č.4 Vytvoření jointů u jednotlivých vazeb  
 
Ikona 
 
Název: joint 
Nyní vytvoříme vazby mezi jednotlivými linky v závislosti jejich pohybů v mechanismu. 
Bez vazeb by se mohly linky volně pohybovat v prostoru ,ve kterém máme šest stupňů volnosti. 
 
 Tři posuvy v osách X,Y,Z  
 Tři rotace okolo os X,Y,Z  
1. Klikneme na ikonu Joint 
 Kombinací různých typů vazeb odebíráme potřebné počty volnosti. 
Při otevření tabulky Joint vidíme tři záložky Definition, friction a driver 
 
Nyní projdeme záložku Definition  
 
Jejich konkrétnější popis ukážeme na jednotlivých členech 
  
Type - nastavujeme jednotlivé druhy vazeb  
            jejich počet odebírání stupňů volnosti je uvedeno níže v tabulce 
Action - Určení linku, který koná příslušní pohyb v závislosti na typu  
               vazby 
                
Base - Určení relativního linku (členu)  
            v případě, že link není vybrán je zavazben k virtulárnímu rámu 
Limits - Nastavení maximální nebo minimální oblasti pohybu 
              Je možné aplikovat pouze na Articulation motion v záložce  
              Driver nebo na Revolute a Slider Joint 
 
Settings - Scale - nastavení měřítka zobrazovací značky  
Name - Vložení názvu Jointu              
 
Záložku Friction (tření) je možné nastavit parametry tření  
Popis této záložky přesahuje rámec toho cvičení z toho důvodu se ji  
Věnovat nebudeme. 
 
Záložka Driver - nastavuje hancí části mechanismu, které jsou řízeny  
konstantními, harmonickými nebo funkčními hodnotami.  
 V našem případě postačí položka Constant kde přiřadíme libovolnou hodnotu do řádku 
 Initial Velocity 
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Tabulka : Jednotlivé vazby a jejich odebrání stupňů volnosti 
2. Type - Revolute 
    Vybereme link ozubene_kolecko 
    Specific origin - vybereme středový bod kružnice (osa otáčení ozubeného kola) 
    Specific orientation - osa rotace 
V záložce Drive vyplníme řádek  
Initial Velocity - 50  
(jednotky jsou stupně za sekundu) 
3. Klikneme na Apply 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Joint type 
Odebrání stupňů volnosti 

Posuv Rotace Celkově 

REVOLUTE (rotační) 3 2 5 

Slider (kluzná) 2 3 5 

Cilindrical (válcová) 2 2 4 

Screw (šroubová) speciální vazba 

Uneversal(univerzální) 3 1 4 

Sp
erical (kulová) 3 0 3 

Planar (rovnoběžná) 1 2 3 

Fixed (pevná) 3 3 6 
Constatn velocity (konstantní 

rychlost) 
3 0 3 

Atpoint (k bodu) 2 0 2 

Inline (po přímce) 2 0 1 

Inplane (v rovině) 1 0 1 

Orientation (orientace) 0 3 3 

Parallel (rovnoběžně) 0 2 2 

P
rpendicular (kolmost) 0 1 1 
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4. Nyní vytvoříme joint, opět typu revolute na linku Ozubene_kolo_hridel_drazka_cep   
    Jeho geometrickou orientaci vytvoříme na základě  předchozího jointu (ozubene_kolecko) 
 
 
 
                                                                                                                Bod a osa otáčení ve středu kola 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. Klikneme na Aplly 
 
Dále vytvoříme vazbu mezi čepem a ojnicí (vzdálenější od motoru) 
 
6. Joint vytvoříme na linku Ozubene_kolo_hridel_drazka_cep  
    Type: Cylindrical ( u této vazby je dovolen posuv v ose rotace)  
    Střed otáčení a osu rotace volíme v ose rotace čepu dle obrázku 
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V záložce Base: vytvoříme link Ojnice_1 (Tím "svážeme" pohyb čepu vůči ojnici)  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Další vytvoříme Joint typu Spherical u Ojnice a čepu v kluzném vedení 1 
 
Podíváme-li se na pohyb ojnice, která konám obecný pohyb (rotace u linku 
Ozubene_kolo_hridel_drazka_cep a posuv u linku Kluzne_vedeni_cep_1), je zde jistá podobnost 
klikového mechanismu. Aby nedošlo k převazbení mechanismu je zapotřebí u čepu kluzného vedení 
vytvořit vazbu pomocí Jointu Spherical. 
7. záložka Action - Link: Ojnice_1 
                              - Specify origin: klikneme na ikonu        point dialog 
 
Tabulku Point nastavíme dle obrázku Specify point 1 (střed otáčení na vnější straně) 
                                                                       Specify point 2 (střed otáčení na vnitřní straně) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
8. Kliknem na OK 
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Specify Orientation: je osa otáčení ojnice okolo čepu  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Záložka Base: vybereme  
                        link Kluzne_vedeni_cep_1 
 
 
 
 
 
 
 
 
 
 
 
 
9. Klikneme na Apply 
 
 
Uložíme  
 
          Pohyb ojnice_2 je shodný s pohybem ojnice_1. Ukážeme si ještě jeden způsob jaké vazby u 
ojnice vytvořit, aniž by došlo k vytvoření nadbytečným vazbám v mechanismu. 
  
10. Vytvoříme Joint mezi linky Ozubene_kolo_hridel_drazka_cep a Ojnice_2  
         Záložka - Type: Universal 
                         Action: Ozubene_kolo_hridel_drazka_cep 
Geometrické parametry nastavíme obdobním způsobem jako u bodu č.7      
 
 
 
Vazba universal je také vhodná například pro zavazbení strojní součásti kardanův hřídel. 
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                                                                                                                Bod leží v rovině symetrie ojnice 
 
                                                                                                                 Osa otáčení směr kolmý na   
                                                                                                                 rovinu symetrie ozubeného kola 
 
                                                                                                                    
 
 
 
          - Base: Ojnice_2 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
           - Specify Orientation nastavíme podél hrany ojnice 
11. Klikneme na Apply 
 
Dále vytvoříme vazbu mezi ojnicí a lineárním vedením 
12. Záložka - Type: Spherical 
                    Action: Ojnice_2 
            Bod leží v rovině symetrie ojnice 
Směr orientace kolmý na plochu ojnice 
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- Base: Kluzne_vedeni_cep_2 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
13. Klikneme na Apply 
 
Dále vytvoříme joint mezi Kluzne_vedeni_cep_2 a Motor_vedeni 
 
14. Záložka - Type: Slider 
                    Action: Kluzne_vedeni_cep_2 
            Bod umístíme dle obrázku 
Směr určuje směr pohybu vedení 
  
 
 
 
 
 
 
 
 
 
 
- Base: Motor_Vedeni 
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15. Klikneme na Apply 
16. Stejný postup provedeme u linku Kluzne_vedeni_cep_1 
 
 
 
 
 
 
 
 
 
 
 
 
Zde nepoužijeme záložku Base  
 
17. Klikneme na Apply 
 
18. Následně vytvoříme Joint mezi Kluzne_vedeni_cep_1 a Ramenna_paka 
 
                                                                                                                       Type: Revolute 
 
                                                                                                                      Bod otáčení (střed osy  
                                                                                                                      otáčení čepu) 
 
 
                                                                                                                         
                                                                                                                        Base: Kluzne_vedeni_cep_1 
 
 
 
 
 
 
 
19. Klikneme na Apply 
20. Vytvoříme Joint mezi Ramenna_paka a Kloubova_tyc 
 
                                                                                                                   Type: Spherical 
 
                                                                                                                    Bod otáčení (střed koule) 
                                                                                                                    Směr volíme podél této hrany 
 
                                                                                                                         
                                                                                                                        Base: Kloubova_tyc 
 
                                                                                                                     21. Klikneme na Apply 
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Vytvoříme vazbu mezi kloubovou tyčí a ramenem  
 
22. Vytvoříme Joint mezi Kloubova_tyc a Rameno  
      Konstrukce je analogická s bodem 20 
 
 
 
 
 
 
 
   
                                                                                                     Base: Rameno 
23. Klikneme na Apply 
 
24. Nyní vytvoříme samostatný joint pro link Rameno 
                                                                                                                   Type: Revolute 
 
                                                                                                                    Bod otáčení (střed náboje) 
                                                                                                                    Směr kolmý k této ploše 
 
                                                                                                                         
                                                                                                                        Base: Ponecháme prázdný 
 
                                                                                                                                                                          
                                                                                                                     25. Klikneme na Apply 
 
 
 
 
 
 
26. Joint mezi Ramenem a kulovou tyčí 
Záložka - Type: Slider 
                Action: Kulova_tyc 
Směr určuje směr pohybu kolmý na plochu ramena           Bod umístíme dle obrázku do středu nákružku 
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      Base: Rameno 
27. Klikneme na Apply 
 
           Nyní se přesuneme zpět k tyči, objímce, lineárnímu vedením a ramenu. U této soustavy nelze 
vytvořit vazby typu revolute, slider a další. Musíme použít tak zvané primitivní vazby, které odebírají 
stupně volnosti na základě jejich nadefinovaných vlastností v programu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Nejprve vytvoříme vazbu u tyče a lineárního vedení 
28. Záložka - Type: Atpoint 
                    Action: Tyc 
 
Bod umístíme do roviny symetrie tyče a osy otáčení čepu 
Směr bude kolmý na tuto plochu 
 
 
 
 
 
 
 
 
 
 
                                                                                                 Base: Kluzne_vedeni_cep_2 
 
 
29. Klikneme na Apply 
30. Záložka - Type: Perpendicular 
                   Action: Tyc 
 
 
                                                                                                                    Směr kolmý na tuto plochu 
                                                                                                                     Bod střed kružnice 
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Base: Kluzne_vedeni_cep_2 
 
 
 
 
Směr kolmý na tuto plochu 
 
 
 
 
 
 
 
 
 
31. Klikneme na Apply 
 
32. Záložka - Type: Inplane 
                   Action: Tyc 
 
 
Bod střed kružnice  
Směr totožný s osou Z CSS 
 
 
 
Base: Objimka 
33. Klikneme na Apply 
 
                                       
                                                                                       Nyní se přesuneme k objímce 
                                                                                 34. Záložka - Type: Paralle 
                                                                                                     Action: Tyc 
 
                                                                                       Bod střed kružnice  
                                       
 
 
 
 
 
 
 
Směr vytvoříme pomocí dvou bodu, které  
vytvoříme dle obrázku. 
 
 
 
 
 
 
Base: Objimka 
35. Klikneme na Apply 
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36. Záložka - Type: Inline 
                   Action: Tyc  
 
 
Bod střed kružnice 
 
 
Směr je kolmý na tuto  
plochu objímky 
 
 
      Base: Objimka 
37. Klikneme na Apply 
                                                                                38. Záložka - Type: Atpoint 
                                                                                                    Action: Objimka 
 
 
                                                                                                   Bod umístíme do roviny symetrie objímky  
                                                                                                   a osy otáčení čepu směr bude kolmý na  
                                                                                                   tuto plochu 
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                            
 
 
 
 
 
 
 
 
Base: Rameno 
39. Klikneme na Apply 
Nyní vytvoříme křivku, která bude tvořit cestu kulového kloubu v drážce. Přepneme se do modeláře. 
Poté roletové menu Window z Obecny_mechanismu.sim se přepneme do Obecny_mechanismus.prt 
Na komponentu vačka utvoříme křivku 
40. V roletovém menu Insert→Curve from Curves→Offset...  
 Pod ikonovým menu zadáme výběrovou úroveň Within work Part Only a výběr křivek bude Tangent 
Curves. Tabulku nastavíme dle obrázku. 
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41. Křivku vybereme dle obrázku 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
42. Klikneme na OK 
Přepneme se zpátky do Motion Simulation 
43. Nyní v ikonovém menu vybereme Ikonu            Point on Curve. V roletovém menu  
      Insert→Constraint→Point on Curve 
 
44. Bod vybereme středový bod kloubu  
45. Křivku vybereme dle obr. 
 
 
 
 
 
 
 
 
 
 
                                                                                         46. Klikneme na OK 
 
 
                                                                                         V Motion Navigator přibila ikona Constrain 
Dále vytvoříme pružinu mezi Kulovou tyčí a Ramennou pákou 
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47. V ikonovém menu vybereme ikonu          Spring. V roletovém menu Insert→Connector→  
       Spring...  
48. Záložka Action vybereme Link Kulova_Tyc 
      Zvolený bod bude horní část nákružku  
                                                                                         49. Záložka Base vybereme Link Rameno  
                                                                                               Bod bude ve středu kružnice linku Rameno                                                                                           
                                                                                               dle obrázku. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
51. Záložku Stiffness ponecháme defaultně nastavenou                                                                                        
52. Záložku Free lenght nastavíme na 500 mm (pružina bude v předepjatém stavu) 
53. Klikneme na OK 
54. Při přepnutí do drátěného modelu vidíme schematický znázorněnou pružinu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Nyní vytvoříme vazbu mezi ozubenými koly. 
55. V ikonovém menu vybereme ikonu        Gear. V roletovém menu Insert→Coupler→Gear...  
 
   
 
56. V tabulce Gear vybereme první joint buď to na pracovní ploše dle obrázku nebo v Motion 
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Navigatro Joints→j002 
 
                                                                                           57. V záložce Second joint bude joint u  
                                                                                                 velkého ozubeného kola. 
                                                                                                 Motion Navigatro Joints→j003 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
58. Záložka Settings vložíme převodový poměr dle počtu zubů Z1/ Z2 [28/97] 
59. Klikneme na OK 
Celkový strom 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Simulaci uložíme uložíme. 
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Krok č.5 Nastavení výpočtu a vložení tabulky 
1. V Motion Navigator klikneme pravým tlačítkem myši na ikonu Obecny_mechanismus_1 a v dolní 
části nabídky vybereme New Solution... 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Otevře se tabulka Solution 
 
                                                           V rámci rozsahu tohoto cvičení nám postačí nastavení, které je  
                                                           zobrazeno na obrázku. 
 
                                                          Položky Solution type a Analysis type zůstanou vždy nezměněny 
                                                          Budeme většinou měnit položku Time a Steps 
                                                         
                                                          Zaškrtnem Solve with OK 
 
                                                           Záložku Gravity budem volit vzhledem k orientaci modelu v   
                                                           našem případě se bude jednat o směr  
 
 
 
 
                                                             2. Klikneme na OK 
 
 
                                                                 Proběhne výpočet 
 
 
V Motion Navigator přibyl další prvek Solution. 
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3. V ikonovém menu spustíme animaci 
13. Klikneme na OK 
 
Klikneme na ikonu Play 
 
Proběhne animace mechanismu. 
 
Vytvoříme tabulku zrychlení linku Kluzne_vedeni_cep_1  
 
4. V Motion Navigator klikneme pravým tlačítkem 
    myši na XY-Graphing→New... 
 
 
 
 
                                                             5.   V Záložce Motion Object  
                                                                    Vybereme joint J008 (Kluzne_vedeni_cep_1) 
                                                                    Request - Acceleration 
                                                                    Component - Magnitude (zaškrtneme Absolute - výsedek se  
                                                                    bude stahovat k CSS) 
                                                                    Záložka Y-Axis Definition klikneme na ikonu       . To  
                                                                    způsobí přetáhnutí zadaných parametrů v Motion Objects do                                                               
                                                                    popisové osy Y  
                                                                    Záložka X-Axis Definition Ponecháme Time  
                                                                    Pro jiné případy je možné nastavit X-ovou osu dle vlastní  
                                                                    potřeby zaškrtnutím tlačítka User defined 
 
                                                             6. Klikneme na Ok 
 
                                                             Graf se nám vykreslí do nového okna. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Je-li zapotřebí simulaci ukončit klikneme na ikonu           Finish Animation 
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7. Přepnutí zpátky do prostředí mechanismu, učiníme tak že v Motion navigator 
rozklikneme pod Solution_1→Results→Animation a zaškrtneme Default animation 
 
 
 
 
 
 
 
 
 
Nyní si ukážeme jak rozdělit pracovní plochu na dvě obrazovky, abychom mohli 
sledovat současně pohyb mechanismu a průběh zrychlení v grafu 
 
8. V roletovém menu View→Layout→Side by Side 
 
 
 
 
 
 
 
 
 
 
    Pracovní prostředí rozdělené na dvě části 
9. Dvakrát poklepáme levým tlačítka myši na Graf  
    (J008->MAG,Acceleration(abs)) 
 
10. Vybereme jednu z pracovních ploch 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Nyní můžeme pozorovat mechanismus a graf současně 
11. Zpětné nastavení v roletovém menu View→Layout→Single View 
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Kapitola 2 - Kompresor a řemenový převod 
 
V této kapitole si ukážeme použití 2-3 joint Coupler vazby. 
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Krok č.1 Otevření sestavy 
    

1.   Klikněte na 
 
2.   V okně OPEN otevřete položku mechanismus (Najdete jej ve vámi zvoleném adresáři s uloženými   
      CAD daty). 
3.   Dole klikněte na  Options... → Model data → zaškrtněte surface a solids 
 
4.   Potvrďte tlačítkem OK .   
 
 
 
 
 
 
 
 
 
Potřebné CAD data naleznete na courseware u  
předmětu KKS/KPP  → Studijní materiály →   
sw NX → Založka mechanismu.          
 
 

Krok č.2 Přepnutí do Motion simulation 
1. V ikonovém menu  na ikonu                    po jejím rozbalení přejdeme do prostředí  Motion  
    Simulation  (mechanismu). 
 
 
 
 
 
 
 
 
 
2. V Motion Navigator klineme pravým tlačítkem myši na  
kompresro_a_remenice a dáme New Simulation. 
3. V okně Enviroment záložce Analysis type označíme  
    Dynamics a Component-based Simulation 
    Ostatní položky necháme odškrtnuté. 
4. Klikneme na OK 

 
Simulaci uložíme. 
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Krok č.3 Vytvoření jednotlivých linků 
1. Klikneme na ikonu Link a vybereme všechny nepohybující se součásti (Motor,Řemen,Vanu, 
ložiska, tělo,válec, ventilová deska a hlava)  
 
 
 
Řemen je pouze pro optické znázornění přenosu síly z motoru na stroj. Spojíme jej pomoci funkce  
2-3 Joint Coupler v dalším kroku. 
 
Do položky Name - Pevne_soucasti 
 
 
2. Klikneme na Apply 
 
 
 
 
 
 
 
 
3. Dále vybereme Šroub, podložku, řemeničku 
 
 
 
    Name - Remenicka 
 
 
 
 
 
 
 
4. Klikneme na Apply 
5. Dále vybereme Šroub, podložku, řemenici, trubku a klikový hřídel 
 
Name - Remenice_klikovy_hridel 
 
 
 
 
 
 
 
 
 
6. Klikneme na Apply 
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7. Vybereme ojnici  
 
Name - Ojnice 
 
 
 
 
 
 
 
 
 
 
 
 
8. Klikneme na Apply 
 
 
 
 
9. Vybereme Píst a čep  
 
Name - Pist_cep 
 
 
10. Klikneme na Apply 
 
 

 
Simulaci uložíme. 
 

Krok č.4 Vytvoření jointů u jednotlivých vazeb 
1. Klikneme na ikonu Joint 
2. Type - Revolute 
    Vybereme link Remenicka 
    Specific origin - vybereme středový bod kružnice  
    (osa otáčení řemeničky) 
    Specific orientation - osa rotace 
V záložce Drive vyplníme řádek  
Initial Velocity - 20 
 
 
 
 
 
 
3. Klikneme na Apply 
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4. Type - Revolute 
    Vybereme link Remenice_klikovy_hridel 
    Specific origin - vybereme středový bod kružnice  
    (osa otáčení řemeničky) 
    Specific orientation - osa rotace 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. Klikneme na Apply 
 
6. Type - Cylindrical 
    Vybereme link Ojnice 
    Specific origin - Vytvoříme středový bod v rovině symetrie ojnice a osy otáčení klikového čepu  
    Specific orientation - osa rotace 
 
 
 
 
 
 
 
 
 
 
 
 
 
Base - Remenice_klikovy_hridel 
 
5. Klikneme na Apply 
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6. Type - Cylindrical 
    Vybereme link Ojnice 
    Specific origin - Vytvoříme středový bod v rovině symetrie ojnice a osy otáčení klikového čepu  
    Specific orientation - osa rotace 
 
 
 
 
 
 
 
 
 
 
 
 
Base - Ojnice 
 
7. Klikneme na Apply 
8. Type - Slider 
    Vybereme link Pist_cep 
    Specific origin - Vytvoříme středový bod v rovině symetrie pístu  
    Specific orientation - osa rotace 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
9. Klikneme na Ok 
 
Poslední krok bude vytvoření vazby, která nahradí řemenový převod. 
 
10. Klikneme na ikonku          2-3 joint Coupler (Může být skryta pod ikonou       ). V roletovém menu   
      Insert→Coupler→2-3 joint Coupler... 
 
Coupler→2-3 joint Coupler - Slouží k vytvoření převodu mezi dvěma nebo třema rotačními   
                                                   (revolute), posuvnou(slider) a válcovou (cylindrical) vazbou (joint). 
                                                - vhodný pro řemenové převody, nebo řetězový převod na kole dále pak  
                                                  převody mimo běžnými osami  
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                                                        Attachment type - Two-joint Coupler - umožní převod mezi  
                                                                                        dvěma jointy  
                                                                                      - Three-joint Coupler - umožní převod mezi 
                                                                                         třema jointy  
 
 
                                                          Příklad vysvětlení jak použít Scale (měřítko) u First Joint-Driver  
                                                         a Second Joint-Coupled 
 
                                                         Otočí-li se první(hnací) člen jdenou a druhý(hnaný) člen dvakrát. Je 
                                                         zapotřebí do záložky  First Joint-Driver do položky Scale - 2.00 a                                                                                                                    
                                                         do záložky Second Joint-Coupled do položky Scale - 1.00  
                                                         11. Označíme First Joint-Driver (řemenička u motoru)  
                                                               Scale - 65/100 (roztečný průměry) 
 
 
 
 
 
 
12. Označíme Second Joint-Coupled  
      (řemenice u kompresoru)  
 
 
 
 
 
 
                                                                                     13. Klikneme na OK 
 
                                                                                     Seznam konečných linků 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
14. Nastavíme výpočet a klikneme na OK 
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15. Simulaci spustíme přes ikonu Play 
 
 
 
15.  Pro ukončení klikneme na ikonu           Finish Animation 
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Kapitola 3 - Ovládání ventilů SOHC  
 
V této kapitole si ukážeme použití 3D vazby a vytvoření videa. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



                                                                                                                                                                                 

 37 

Krok č.1 Otevření sestavy 
    

1.   Klikněte na 
 
2.   V okně OPEN otevřete položku mechanismus (Najdete jej ve vámi zvoleném adresáři s uloženými   
      CAD daty). 
3.   Dole klikněte na  Options... → Model data →  
      zaškrtněte surface a solids 
4.   Potvrďte tlačítkem OK .   
 
 
 
 
 
 
 
 
 
Potřebné CAD data naleznete na courseware u  
předmětu KKS/KPP  → Studijní materiály →   
sw NX → Založka mechanismu.          
 
 

Krok č.2 Přepnutí do Motion simulation 
1. V ikonovém menu  na ikonu                    po jejím rozbalení přejdeme do prostředí  Motion  
    Simulation  (mechanismu). 
 
 
 
 
 
 
 
 
 
2. V Motion Navigator klineme pravým tlačítkem myši na  
    engine_sohc a dáme New Simulation. 
3. V okně Enviroment záložce Analysis type označíme  
    Dynamics a Component-based Simulation 
    Ostatní položky necháme odškrtnuté. 
4. Klikneme na OK 

 
Simulaci uložíme. 
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Krok č.3 Vytvoření jednotlivých linků 
1. Klikneme na ikonu Link a vybereme nepohybující se čep sání 
 
 
Do položky Name - otocny_cep_sani 
(Jedná se o ventil s menším průměrem) 
Zaškrtneme Fix 
 
2. Klikneme na Apply 
 
 
 
 
 
 
 
 
3. Dále vybereme čep výfuku 
 
Zaškrtneme Fix 
 
Name - otocny_cep_vyfuk 
 
 
 
 
 
4. Klikneme na Apply 
 
 
5. Dále vybereme Vačkový hřídel 
 
Name - Vacka 
 
 
 
 
 
 
 
 
6. Klikneme na Apply 
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7. Dále vybereme Vahadlo sání 
 
Name - Vahadlo_sani 
 
8. Klikneme na Apply 
 
 
 
 
 
 
9. Dále vybereme Vahadlo výfuku 
 
Name - Vahadlo_vyfuk 
 
 
 
 
10. Klikneme na Apply 
 
 
 
 
11. Dále vybereme váleček sání 
 
Name - Valecek_sani 
 
 
 
 
 
 
12. Klikneme na Apply 
 
 
 
13. Dále vybereme váleček výfuku 
 
Name - Valecek_vyfuk 
 
 
 
 
 
 
 
 
14. Klikneme na Apply 
 
 
 



                                                                                                                                                                                 

 40 

 
15. Dále vybereme ventil sání a sedlo ventilu 
 
Name - Ventil_sani_sedlo 
 
 
 
 
 
 
 
 
 
 
 
 
16. Klikneme na Apply 
 
 
 
 
17. Dále vybereme ventil výfuku a sedlo ventilu 
 
Name - Ventil_vyfuk_sedlo 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
18. Klikneme na Apply 
 
 
 

 
Simulaci uložíme. 
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Krok č.4 Vytvoření jointů u jednotlivých vazeb 
1. Klikneme na ikonu Joint 
2. Type - Revolute 
    Vybereme link Vacka 
    Specific origin - vybereme středový bod kružnice  
    (osa otáčení vačky) 
    Specific orientation - osa rotace 
V záložce Drive vyplníme řádek  
Initial Velocity - 20 
 
 
Base - Je prázdný 
 
 
 
3. Klikneme na Apply 
 
4. Type - Revolute 
    Vybereme link Valecek_sani 
    Specific origin - vybereme středový bod kružnice  
    Specific orientation - osa rotace 
 
 
 
 
 
 
Base - vahadlo sani 
 
 
 
 
 
5. Klikneme na Apply 
 
6. Type - Revolute 
    Vybereme link Vahadlo_sani 
    Specific origin - vybereme středový bod kružnice  
    Specific orientation - osa rotace 
 
   Base - otocny_cep_sani 
 
7. Klikneme na Apply 
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8. Type - Slider 
    Vybereme link Ventil_sani_sedlo 
    Specific origin - vybereme středový bod kružnice  
    Specific orientation - osa rotace 
 
   Base - Je prázdný 
 
9. Klikneme na Apply 
 
 
 
 
 
 
 
 
 
 
 
 
10. Type - Revolute 
    Vybereme link Valecek_vyfuk 
    Specific origin - vybereme středový bod kružnice  
    Specific orientation - osa rotace 
 
   Base - Vahadlo_vyfuk 
11. Klikneme na Apply 
                                                                
 
 
 
 
 
 
 
                                                                
                                                                  12. Type - Revolute 
                                                                           Vybereme link Vahadlo_vyfuk 
                                                                         Specific origin - vybereme středový bod kružnice  
                                                                         Specific orientation - osa rotace 
 
                                                                   Base - Otocny_cep_vyfuk 
 
                                                                   13. Klikneme na Apply 
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10. Type - Slider 
    Vybereme link Ventil_vyfuk_sedlo 
    Specific origin - vybereme středový bod kružnice  
    Specific orientation - osa rotace 
 
   Base - Je prázdný 
 
11. Klikneme na Apply 
 
 
 
 
 
 
Nyní vytvoříme pružinu pro sací ventil. 
 
12. Vybereme ikonu           Spring. 
 
     Záložka Action vybereme Link Ventil_sani_sedlo 
     Bod bude střed této kružnice  (fiktivní dosedací plocha pružiny)   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
13. Záložka Base link zůstane prázdný, ale vytvoříme bod, který nejprve umístíme do středu kružnice.  
      V horní části ventilu. 
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14. Záložku Offset nastavíme dle obrázku. (Along Vector jedná se o tuto úsečku) 
 
                
 
 
 
                                                                                                            V případě obráceného směru  
                                                                                                            Vektoru do kolonky distance  
                                                                                                             vložíme hodnotu -70 mm 
 
 
 
 
 
 
 
 
 
 
Zbytek tabulky nastavíme dle obrázku 
 
 
 
 
 
 
 
 
 
15. Klikneme na OK  
 
Pružinu na ventilu na výfuku vytvoříme obdobným způsobem. 
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Nyní vytvoříme 3D kontakt mezi vačkou a mezi sebou pohybujícími se členy 
 
16. V ikonovém menu vybereme ikonu          3D Contact. V roletovém menu Insert→Connector→  
       3D Contact...  
  
 
3D Contact Vybírá pouze solidová tělesa(zanedbává linky) 
17. Vybereme první tuhé těleso Valecek_vyfuk 
18. Vybereme druhé tuhé těleso Vacka 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Záložku paremeters nastavíme dle obrázku. 
19. Klikneme na Apply 
 
20. Vybereme první tuhé těleso Valecek_sani 
21. Vybereme druhé tuhé těleso Vacka 
 
 
 
 
 
 
 
 
22. Klikneme na Apply 
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23. Vybereme první tuhé těleso Váleček ve vahadle sání 
24. Vybereme druhé tuhé těleso Ventil sání 
 
 
 
 
 
 
 
 
 
 
25. Klikneme na Apply 
 
 
 
 
26. Vybereme první tuhé těleso Váleček ve vahadle výfuku 
27. Vybereme druhé tuhé těleso Ventil výfuku 
 
 
 
 
 
 
 
 
28. Klikneme na Apply 
 
Seznam konečných linků 
 
 
                                                         29. Nastavíme výpočet dle obrázku a klikneme na OK 
 
 
 
                                                                                                          Tento výpočet bude trvat delší dobu.  
                                                                                                           Doba výpočtu je závislá na  
                                                                                                           hardwaru vašeho PC. Výpočet je  
                                                                                                           delší z důvodu použití 3D kontaktu.  
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Nyní vytvoříme video  
 
30. V Roletovém menu  View→Visualization→Create Animation... 
31.  Zobrazenou tabulku High Quality image Animation  nastavíme dle obrázku. Kliknutím na    
       Add/Copy přidáme Moje_video do tabulky pod Default 
      
32. Klikneme na Key Frames 
33. Tabulku vyplníme dle obrázku  
 
 
 
 
 
 
 
 
 
 
 
 
 
34. Klikneme na OK 
35. V tabulce High Quality image Animation v záložce Edit otevřeme Parametrs a tabulku  
       nastavíme dle obrázku a poté klikneme na OK 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
36. Ukončíme tabulku High Quality image Animation kliknutím na Cancel 
37. V Roletovém menu  File→Export→MPEG2... 
 
38. Kliknutím na položku Specify File Name. Zadáme složku 
      kam chceme soubor nahrát a nazveme jej  
      např. SOHC_Video 
39. Klikneme na OK 
   
 
 
 
Velikost souboru by neměla být větší ne 10MB 
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Kardanův hřídel, převodovka a lineární zvedák 

 
V tomto cvičení si uživatel vyzkouší sám vytvoření svého vlastního mechanismu  
Potřebná CAD data naleznete na stránkách předmětu KKS/KPP 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Doporučení: U kardanova hřídele použijeme dvě vazby Universal Joint a jednu vazbu Cylindrical a   
                     schováme kompotnent Kriz_dolni a Kriz_horni 
                     U šroubového zvedáku použijeme mezi maticí a lichoběžníkovým závitem vazbu  
                     2-3 joint Coupler 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
KKS/KPP NX UNIGRAPHICS MECHANISMUS 
 
doc. Ing. Martin Hynek, Ph.D. 
Bc. Eduard Müller 
Ing. Petr Votápek 
Ing. Zdeněk Raab 
 
 
Vydavatel:  Západočeská univerzita v Plzni, Vydavatelství 

Univerzitní 8, 306 14 Plzeň 
tel.: 377 631 951 
e-mail: vydavatel@vyd.zcu.cz 

 
Katedra:  konstruování strojů 
Vedoucí katedry:  doc. Ing. Václava Lašová, CSc. 
Určeno:  pro studenty FST 
Vyšlo:   březen 2012 
Počet stran:   52 
Nositelé  
autorských práv: autoři 
   Západočeská univerzita v Plzni 
Vydání:  1. vydání, on-line 
Číslo publikace:  2068 
 
Tato publikace neprošla redakční ani jazykovou úpravou. 
 
 
 

55 - 056 - 12 
 

17/51  
   



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Tento projekt je spolufinancován Evropským sociálním fondem a 
státním rozpočtem České republiky v rámci projektu 

č. CZ.1.07/2.2.00/07.0235 „Inovace výuky v oboru konstruování 
strojů včetně jeho teoretické, metodické a počítačové podpory“. 

doc. Ing. Martin Hynek, Ph.D. 
 Bc. Eduard Müller 
 Ing. Petr Votápek 
 Ing. Zdeněk Raab 
 


	mechanismus.pdf
	MECHANISMU 


